Задать вопрос

Дано 4-х значное число. Определить, что больше само число или его перевёртыш.

+4
Ответы (1)
  1. 13 декабря, 20:31
    0
    program zz1;

    var a, k, s:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное четырехзначное число '); / / вводим число с клавиатуры

    read (k);

    a:=k mod 10; k:=k div 10; / / получаем первую цифру перевертыша

    while k0 do / / переворачиваем число

    begin

    s:=k mod 10; / / получаем последнюю цифру

    k:=k div 10; / / отбрасываем ее из числа

    a:=a*10 + s; / / формируем новое число

    end;

    if k > s / / проверяем, что больше само число или его перевертыш

    then writeln (' само число больше ') else writeln (' перевертыш больше '); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано 4-х значное число. Определить, что больше само число или его перевёртыш. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Составить программу в Pascal. В которую введя любое трехзначное число оно выводит число-перевертыш (пример ввожу 122 и мне выводит 121 или 569 и и мне 565)
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)