Задать вопрос

Найти сумму 10 членов арифметической прогрессии A, A+D, A+2D, ..., где А - первый член прогрессии, D - постоянное слагаемое, разность прогрессии. Паскаль

+1
Ответы (1)
  1. 13 февраля, 03:07
    0
    program zz1;

    var a, d, r, i:integer; / / задаем переменные целого типа

    begin

    write (' введите первый член арифметической прогрессии '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите разность арифметической прогрессии '); / / вводим с клавиатуры второе число

    read (d);

    for i:=0 to 9 do / / задаем цикл на десять повторений

    r: = r + a + i * d; / / вычисляем сумму, прибавляя к ней очередной член арифметической прогрессии

    write (' сумма 10 членов арифметической прогрессии = ', r); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму 10 членов арифметической прогрессии A, A+D, A+2D, ..., где А - первый член прогрессии, D - постоянное слагаемое, разность ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Вычислить значение переменной Y при заданном значении N: Y=1/1+1/2+1/3 + ... + 1/N. использовать цикл типа ДО. (Паскаль) 2. Найти все целые двузначные числа, удовлетворящие условию: остаток от деления на 3 равен 2. (Паскаль)
Ответы (1)
Дано: а-первый член геометрической прогрессии, знаменатель-q, n-количество членов. вывести на экран все члены геом. прогрессии и их среднее арифметическое (в паскале)
Ответы (1)
Запишите на языке Паскаль следующие условия. Условие Запись на языке Паскаль х не кратно 7 У ≠ 0 - 5
Ответы (1)
Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс
Ответы (1)
1. Нахождение наибольшего элемента главной диагонали. (Паскаль, двумерные массивы) 2. Нахождение наименьших элементов в столбцах массива. (Паскаль, двумерные массивы)
Ответы (1)