Задать вопрос

Дан массив X (n*m)). Элементы массива ввести с клавиатуры. Найти количество элементов кратных 5. Паскаль

+1
Ответы (1)
  1. 3 июня, 06:11
    0
    program zz1;

    const n = 3;

    m = 3; / / задаем количество элементов в массиве

    var i, j, k:integer; / / задаем переменные целого типа

    x:array [1 ... n, 1 ... m] of integer;

    begin

    for i:=1 to n do

    for j:=1 to m do / / вводим числа с клавиатуры и записываем их в массив

    read (x[i, j]);

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to m do

    write (x[i, j]:4);

    writeln;

    end;

    for i:=1 to n do

    for j:=1 to m do

    if x[i, j] mod 5 = 0 then k:=k + 1;

    writeln (' количество элементов массива кратных 5 = ', k); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив X (n*m)). Элементы массива ввести с клавиатуры. Найти количество элементов кратных 5. Паскаль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от 0 до 1000. Напишите программу, позволяющую найти и вывести количество элементов массива, кратных трём, запись которых заканчивается цифрой 1. Паскаль АБС
Ответы (1)
Дан массив B (n*m). Элементы массива ввести в программе. Поменять местами максимальный и минимальный элемент. Паскаль двумерный массив пример присвоения элементов массива в программе : b: array[1 ... n, 1 ...
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)