Задать вопрос

Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру нахождения 3 максимальных элементов массива, которые не равны друг другу

+1
Ответы (1)
  1. 5 октября, 15:29
    0
    Var

    arr:array[0 ... 1000] of integer;

    n, i: integer;

    procedure tri_el; {процедура которая выводит на экран первые 3 элемента из массива, которые не равны друг другу }

    var

    q, j: integer;

    o:array[1 ... 3] of integer; { массив чисел, которые не равны друг другу }

    begin

    write (arr [1],' ');

    q:=1;

    o[q]:=arr[1];

    i:=1;

    while q3 do

    begin

    i:=i+1;

    if q=1 then

    if arr[i]o[1] then

    begin

    write (arr[i],' ');

    q:=q+1;

    o[q]: = arr[i];

    end;

    if q=2 then

    if (arr[i]o[1]) and (arr[i]o[2]) then

    begin

    write (arr[i]);

    q:=q+1;

    end;

    end;

    end;

    procedure tri_max; {процедура нахождения 3 максимальных элементов массива, которые не равны друг другу} var

    mks:array[1 ... 3] of integer; {массив максимальных значений} begin

    for i:=1 to 3 do

    mks[i]:=0;

    for i:=1 to n do

    if mks[1]< arr[i] then

    begin

    mks[3]:=mks[2];

    mks[2]:=mks[1];

    mks[1]: = arr[i];

    end else

    if (mks[2]< arr[i]) and (arr[i]mks[1]) then

    begin

    mks[3]:=mks[2];

    mks[2]: = arr[i];

    end; else

    if (mks[3]< arr[i]) and (mks[2] arr[i]) then mks[3]: = arr[i];

    write (mks[1],' ', mks[2],' ', mks[3]); {вывод на экран 3 максимальных элементов массива, которые не равны друг другу }

    end;
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Pascal ABC. Написать процедуру, которая выводит на экран первые 3 элемента из массива, которые не равны друг другу. Или процедуру ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массив состоящий из n элементов. вывести максимальный элемент массива и его индекс. Если в массиве содержится несколько максимальных элементов, посчитать количество максимальных элементов, вывести максимальное значение и индексы элементов его
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Составить программу, которая вводит с клавиатура массив из 5 целых чисел и выводит на экран значение четвертого элемента массива. 2. Дан массив из 10 элементов, заполненный удвоенными значениями индексов элементов массива.
Ответы (1)
Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов. программа: Pascal ABC.
Ответы (1)