Задать вопрос

Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов. программа: Pascal ABC.

+5
Ответы (1)
  1. 20 апреля, 07:05
    -1
    Const

    n = 25;

    var

    a: array[1 ... n] of integer;

    i, s: integer;

    begin

    Writeln ('Введите элементы массива');

    s : = 0;

    for i : = 1 to n do

    begin Read (a[i]); s : = s + a[i] end;

    Writeln ('Среднее значение элементов массива равно ', s/n)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
С клавиатуры последовательно вводятся 15 разных целых чисел, которые размещаются в массиве. Напишите программу, которая выводит на экран количество элементов массива кратных 5 и минимальное среди подходящих под это условие.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)