Задать вопрос
5 ноября, 00:48

10 спортсменов-многоборцев принимают участие в соревнованиях по 5 видам спорта. По каждому виду спорта спортсмен набирает определенное количество очков. Спортсмену присваивается звание мастера, если он набрал в сумме не менее к очков. Сколько спортсменов получило звание мастера?

+4
Ответы (1)
  1. 5 ноября, 03:48
    0
    program zz1;

    var i, j, k, s, a, b:integer;

    begin

    write (' введите заданное k');

    read (k);

    for i:=1 to 10 do / / перебираем в цикле спортсменов

    begin

    for j:=1 to 5 do / / перебираем виды спорта

    begin

    writeln (' введите количество очков ', i,'-го спортсмена по ', j,'-му виду спорта');

    read (a);

    s:=s+a; / / получаем сумму очков для очередного спортсмена

    end;

    if s>k then begin writeln (i,'-ый спортсмен получил звание мастера '); b:=b + 1; end;

    s:=0;

    end;

    write (' количество спортсменов получивших звание мастера = ', b); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «10 спортсменов-многоборцев принимают участие в соревнованиях по 5 видам спорта. По каждому виду спорта спортсмен набирает определенное ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Выполнить алгоритм: 1) Найти сумму чисел 1 и 3; 2) Прибавить к полученной сумме число 5; 3) Прибавить к полученной сумме число 7; 4) Прибавить к полученной сумме число 9; 5) Прибавить к полученной сумме число 11; 6) Сообщить результат
Ответы (1)
Написать программу которая задает с клавиатуры рост 10 спортсменов из диапазона от 150 до 200 см считает количество спортсменов рост которых больше 190 см а также средний рост всех спортсменов
Ответы (1)
Петя набирает документ в течение 3 минуты объём документа составлял 1 килобайт. Какой объём будет у другого документа который Петя набирает в течении 5 минут если известно что скорость в 2 раза меньше.
Ответы (1)
Дан условный оператор: if a5 then c:=2else c:=3 Какое значение имеет переменная a, если в результате выполнения условного оператора переменной c присваивается значение 3?
Ответы (1)
Лепрекон Вася, снимая с карты часть своих денег (коинов) в банкомате " Лепрекон-Банка", при вводе снимаемой суммы набрал последовательно #,æ, Q. Позже, снимая деньги, он набрал последовательно æ,#, Q.
Ответы (1)