Задать вопрос

Паскаль. Составить программу введённого пользователем числа (целое или нет; положительное, отрицательное или нуль; чётное или нечётное)

+1
Ответы (1)
  1. 26 января, 18:46
    0
    program zz1;

    var n:string; / / задаем переменную строкового типа

    begin

    write (' введите n '); / / вводим с клавиатуры число

    read (n);

    if (pos (',', n) = 0) then writeln (' число целое ') else writeln (' число не целое ');

    if n[1] = '-' then writeln (' число отрицательное ') else if n[1] = '0' then writeln (' число равно нулю ')

    else writeln (' число положительное ');

    if (n[length (n) ] = '0') or (n[length (n) ] = '2') or (n[length (n) ] = '4')

    or (n[length (n) ] = '6') or (n[length (n) ] = '8') then writeln (' число четное ') else writeln (' число не четное ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Паскаль. Составить программу введённого пользователем числа (целое или нет; положительное, отрицательное или нуль; чётное или нечётное) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике