Задать вопрос

Составить программу, которая определяет четное число или нет? Программа генерирует случайное число с помощью Rаndom и выводит само число и фразу "чётное" или "нечётное".

+3
Ответы (1)
  1. 24 января, 15:12
    0
    program zz1;

    var n:integer; / / задаем переменную целого типа

    begin

    n:=random (21); / / записываем в переменную случайное число от нуля до двадцати

    writeln (n); / / выводим полученное случайное число на экран

    if n mod 2 = 0 then write (' четное ') else write (' нечетное '); / / проверяем условие, если случайное число делится на два без остатка, то выводим ответ 'четное', если не делится на два без остатка, то выводим ответ 'нечетное'

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая определяет четное число или нет? Программа генерирует случайное число с помощью Rаndom и выводит само число и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Напишите программу которая генерирует 10 случайных чисел в диапазоне от 1 до 20 выводит эти числа на экран и вычисляет их среднее арефмитическое
Ответы (1)
1. Напишите программу, которая генерирует 10 случайных чисел от 1 до 20, выводит числа на экран и вычисляет их сред арифм. 2.
Ответы (1)
Напишите программу которая в последовательности натуральных чисел определяет максимальное четное число, программа получает на вход целые числа, кол во введеных чисел неизвестн, последовательность чисел заканчивается числом 0 (горантируя, что хотя бы
Ответы (1)