Задать вопрос

Дана следующая функция y=f (x) : y = 2x - 10, если x > 0 y = 0, если x = 0 y = 2 * |x| - 1, если x < 0 Требуется найти значение функции по переданному x.

+4
Ответы (1)
  1. 28 декабря, 15:50
    0
    program zz1;

    var x, y:integer; / / задаем переменные целого типа

    begin

    write (' введите исходное значение х '); / / вводим с клавиатуры исходное значение х

    read (x);

    if x < 0 then y:=2 * x - 1; / / вычисляем значение функции при отрицательном х

    if x = 0 then y:=0; / / вычисляем значение функции при х равным нулю

    if x > 0 then y:=2 * x - 10; / / вычисляем значение функции при положительном х

    write (' полученное значение функции y = ', y); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана следующая функция y=f (x) : y = 2x - 10, если x > 0 y = 0, если x = 0 y = 2 * |x| - 1, если x < 0 Требуется найти значение функции по ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дана сторона квадрата а. Найти P = 4*a 2) Дана сторона квадрата а. Найти S = a^2 3) Даны стороны прямоугольника a и b. Найти его площадьS=a*b и периметр P = 2 * (a+b). 4) Дана длина ребра куба a.
Ответы (1)
дана функция y=3x^2+1,5 х меняется от 1 до 20 написать программу по паскалю вычислить значение функции в обратном порядке
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Дана база данных (MS Access) "Ученики школы". Напиши запрос. Необходимо получить информацию: все фамилии, которые входят в диапазон от З до Л. Дана база данных (MS Access) "Ученики школы". Напиши запрос.
Ответы (1)
В начальный момент времени записана цифра 0. На каждом из следующих девяти шагов выполняются такие действия: в очередную строку записывается следующая по порядку цифра, после чего записывается предыдущая строка в обратном порядке.
Ответы (1)