Задать вопрос
15 июля, 19:23

Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1 раз

+5
Ответы (1)
  1. Не совсем понятно, что значит число ошибок при вводе?

    Могу предложить такой вариант решения:

    program Dni;

    var

    m:integer;

    Begin

    writeln ('Введите номер месяца');

    readln (m);

    case m of

    1,3,5,7,8,10,12:writeln ('31 день');

    2:writeln ('В високосном году в феврале 29 дне, в обычном году - 28 дней');

    4,6,9,11:writeln ('30 дней');

    else writeln ('В году 12 месяцев. Вы ввели ошибочный номер');

    END.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. С использованием case. Массивы не проходили.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Ввести номер месяца и вывести название времени года. Пример: Введите номер месяца 4 веснаНапишите программу на языке паскаль
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)