Задать вопрос

Определите, что будет выведено на экран после выполнения фрагмента программы: x:=0; y:=5; While y больше 0 do begin y:=y - 2; x:=x + y; end; writeln ('x=', x); Ответ: х=5 3 х=3 5

+5
Ответы (1)
  1. 12 августа, 11:37
    0
    Для того, чтобы определить, что будет выведено на экран после выполнения фрагмента данной программы, пройдемся по ее коду и найдем конечный результат:

    1) x: = 0; y: = 5;

    While y больше 0

    do begin y: = y - 2; (y: = 5 - 2 = 3);

    x: = x + y; (x: = 0 + 3 = 3);

    2) Поскольку полученное значение y = 3 больше нуля, то мы не выходим из цикла while и продолжаем выполнение программы:

    do begin y: = y - 2; (y: = 3 - 2 = 1);

    x: = x + y; (x: = 3 + 1 = 4);

    3) Поскольку полученное значение y = 1 больше нуля, то мы не выходим из цикла while и продолжаем выполнение программы:

    do begin y: = y - 2; (y: = 1 - 2 = - 1);

    x: = x + y; (x: = 4 + (-1) = 3);

    4) Поскольку полученное значение y = - 1 меньше нуля, то мы выходим из цикла while и продолжаем выполнение программы:

    end;

    writeln ('x=', x);

    В результате на экране выведется последнее значение x:

    x = 3.

    Ответ: х = 3.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Определите, что будет выведено на экран после выполнения фрагмента программы: x:=0; y:=5; While y больше 0 do begin y:=y - 2; x:=x + y; ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m'); readln (c, m); s:=c*m; writeln ('s=', s); readln; end.
Ответы (1)