Задать вопрос
30 ноября, 04:57

Составьте программу, выясняющую, является ли данное слово перевертышем (так называются слова, читвющиеся одинаково слева направо и справа налево, например: топот, шалаш)

+2
Ответы (1)
  1. 30 ноября, 05:32
    0
    program zz1;

    var s, s1:string; / / задаем переменные строкового типа

    i:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    for i:=length (s) downto 1 do / / организуем цикл, в котором переберем все символы от последнего до первого

    begin

    s1:=s1 + s[i]; / / формируем новую строку

    end;

    if s1 = s / / проверяем условие, если две строки равны, то

    then write (' исходная строка является перевертышем ') / / выводим один ответ

    else write (' исходная строка не является перевертышем '); / / иначе, выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, выясняющую, является ли данное слово перевертышем (так называются слова, читвющиеся одинаково слева направо и справа ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десяти на запись которого читается одинаково слева направо и справа налево
Ответы (1)
1. Дано трехзначное число. Выяснить, является ли оно палиндромом ("перевертышем"), то есть таким числом, десятичная запись которого читается одинаково слева направо и справа налево
Ответы (1)
Электронные часы показывают время от 00:00 до 23:59. Назовём время на часах счастливым, если оно читается одинаково как слева направо, так и справа налево. Например, это 01:10. Сколько счастливых времён в сутках?
Ответы (1)
Дано слово. Проверить является ли оно ''перевертышем'' (перевертышем называется слово, читаемое одинакого как с начала так и с конца),
Ответы (1)