Задать вопрос

1. Дано трехзначное число. Выяснить, является ли оно палиндромом ("перевертышем"), то есть таким числом, десятичная запись которого читается одинаково слева направо и справа налево

+3
Ответы (1)
  1. 1 февраля, 09:52
    0
    program zz1;

    var a, k, s:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное трехзначное число '); / / вводим число с клавиатуры

    read (k);

    a:=k div 100; / / получаем первую цифру заданного числа

    s:=k mod 10; / / получаем последнюю цифру заданного числа

    if a = s / / проверяем, если первая цифра числа равна последней, то

    then writeln (' число является перевертышем ') / / выводим один ответ

    else writeln (' число не является перевертышем '); / / иначе, выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Дано трехзначное число. Выяснить, является ли оно палиндромом ("перевертышем"), то есть таким числом, десятичная запись которого ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десяти на запись которого читается одинаково слева направо и справа налево
Ответы (1)
Число называется палиндромом, если справа налево и слева направо читается одинаково. Например, 12321 - палиндром. Найдите ближайший палиндром, больший числа 13244. Пример: для числа 12 ближайший палиндром, больший него, это 22.
Ответы (1)
Число называется палиндромом, если справа налево и слева направо читается одинаково. Например, 12321 - палиндром. Найдите ближайший палиндром, больший числа 81247. Пример: для числа 12 ближайший палиндром, больший него, это 22.
Ответы (1)
Составьте программу, выясняющую, является ли данное слово перевертышем (так называются слова, читвющиеся одинаково слева направо и справа налево, например: топот, шалаш)
Ответы (1)