Задать вопрос

Написать программу, которая заменяет все заглавные буквы строчными, а строчные - заглавными в заданной символьной строке. (Паскаль)

+2
Ответы (1)
  1. 19 ноября, 18:06
    0
    Если с кириллическими символами программа работать не будет, то следует удалить строки с четырехзначными значениями для выбора в case и работать только с латинскими.

    program Up_Low;

    var s:string;

    c:integer;

    begin

    writeln ('Введите строку символов с большими и малыми буквами');

    readln (s);

    for i:integer:=1 to length (s) do

    begin

    c: = ord (s[i]);

    case c of

    97 ... 122: write (chr (Ord (c) - 32));

    65 ... 90:write (chr (Ord (c) + 32));

    1025:write (chr (Ord (c) + 80));

    1105:write (chr (Ord (c) - 80));

    1040 ... 1071:write (chr (Ord (c) + 32));

    1072 ... 1103:write (chr (Ord (c) - 32));

    else write (s[i])

    end

    end

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая заменяет все заглавные буквы строчными, а строчные - заглавными в заданной символьной строке. (Паскаль) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая заменяет в символьной строке все буквы a на буквы b (латинские, строчные). В Си
Ответы (1)
1. Что из ниже перечисленного не входит в алфавит языка Паскаль? а) латинские строчные и прописные буквы б) служебные слова в) русские строчные и прописные буквы г) знак подчёркивания
Ответы (1)
Pascal ABC Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере. Пробелы, знаки препинания, заглавные и строчные буквы важны! Ввод: 179 вывод: The next number for the number 179 is 180.
Ответы (2)
Дана строка содержащая текст записанный строчными русскими буквами. получить в другой строке тот же текст записанный заглавными бувами
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)