Задать вопрос

Дано натуральное число. Верно ли, что количество его цифр есть четное число, а само число не превышает b? Написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean

+1
Ответы (1)
  1. 15 июня, 02:58
    0
    program zz1;

    var n1, n, k, b, m:integer;

    begin

    read (n); / /вводим заданное n

    read (b); / /вводим заданную число

    n1:=n; / /запоминаем исходное n

    while n0 do / /повторяем цикл пока исходное число не станет 0

    begin

    m:=n mod 10; / /получаем последнюю цифру

    k:=k+1; / /считаем ее

    n:=n div 10; / /выбрасываем эту цифру из числа

    end;

    if k mod 2=0 then writeln ('количество цифр в числе ', n1,' четно') else writeln ('количество цифр в числе ', n1,' нечетно');

    if n1>b then write ('исходное число ', n1,' превышает ', b) else write ('исходное число ', n1,' не превышает ', b); / / выводим ответ на экран

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число. Верно ли, что количество его цифр есть четное число, а само число не превышает b? Написать программу на паскале ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы