Задать вопрос

Паскаль: Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Сколько километров он пробежит В сумме за семь дней? Составьте программу решения задани в Паскале с помощью WHILE

+4
Ответы (1)
  1. var

    i, x: integer; / / объявляем переменные целочисленного типа.

    y, sum : real; / / объявляем переменные вещественного типа.

    begin

    y : = 10; / / пробег спортсмена в первый день.

    while i < 6 do / / в цикле определяем пробег спортсмена со 2-го по 7-й день.

    begin

    y : = y + (y / 100 * 10); / / пробег спортсмена за i-й день.

    sum : = sum + y; / / считаем сумму километров.

    i : = i + 1; / / счетчик дней недели.

    end;

    write ('В сумме за 7 дней спортсмен пробежал: ', round (sum + 10,2), ' км.'); / /вывод на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Паскаль: Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Начав тренировки спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10 процентов от нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней
Ответы (1)
Turbo Pascal. Спортсмен пробежал 10 км в первый день. Каждый следующий день он увеличивал норму на 10% от нормы предыдущего дня. Определить: a) Через сколько дней он будет пробегать не более 20 км? б) Сколько километров он пробежит на 7-ой день?
Ответы (1)
Начав тренировки, спортсмен пробегает 10 км. Последующие дни он увеличивал свой пробег на 10%. Через, сколько дней суммарный путь спортсмена превысит 100 км. Паскаль. С использованием while
Ответы (1)
Составить программу решения задачи: Спортсмен в первый день пробегает 5 километров, а в каждый следующий день на 10 километров больше, чем в предыдущий. Сколько километров он пробежит в 10-й день? Найти общую сумму пробега за 10 дней
Ответы (1)
Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. Через сколько дней варенье кончится?
Ответы (1)