Задать вопрос
18 февраля, 17:36

Написать программу, которая в зависимости от введенного количества минут (M < = 60) будет подставлять слово минута в нужном падеже Например, 25 минут31 минута53 минуты (используя оператор CASE и операции DIV и MOD)

+2
Ответы (1)
  1. 18 февраля, 18:31
    0
    Можно использовать mod без div:

    program minutes;

    var m: integer;

    begin

    write ('Введите число минут (от 1 до 60) ');

    readln (m);

    case m mod 10 of

    0, 5, 6, 7, 8, 9: writeln (m, ' минут');

    1: writeln (m, ' минута');

    2, 3, 4: writeln (m, ' минуты')

    end

    end.

    Можно использовать div без mod:

    program minutes;

    var m, k: integer;

    begin

    write ('Введите число минут (от 1 до 60) : ');

    readln (m);

    k : = m - (m div 10) * 10;

    case k of

    0, 5, 6, 7, 8, 9: writeln (m, ' минут');

    1: writeln (m, ' минута');

    2, 3, 4: writeln (m, ' минуты')

    end

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая в зависимости от введенного количества минут (M < = 60) будет подставлять слово минута в нужном падеже ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы