Задать вопрос
12 сентября, 11:28

Составить алгоритм для нахождения площади треугольника

+4
Ответы (1)
  1. 12 сентября, 14:52
    0
    program zz1;

    var a, b, c, S, p, d:real; / /задаем переменные не целого типа

    begin

    write ('введите первую сторону треугольника ');

    read (a);

    write ('введите вторую сторону треугольника ');

    read (b);

    write ('введите третью сторону треугольника ');

    read (c);

    d: = (a+b+c) / 2; / /находим полу периметр треугольника

    if (a+b>c) or (a+c>b) or (c+b>a) / /проверяем на существование треугольника, если существует, то вычисляем площадь

    then begin s:=sqrt (d * (d-a) * (d-b) * (d-c)); write ('площадь треугольника = ', s:5:2); end

    else write ('треугольник не существует ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить алгоритм для нахождения площади треугольника ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить алгоритм нахождения НОД трех натуральных чисел, используя вспомогательный алгоритм нахождения НОД двух чисел.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)
Написать алгоритм: Даны 2 числа a и b оба вводятся с клавиатуры, написать алгоритм нахождения наибольшего из них
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)