Задать вопрос

Вычислите, чему равняется значение переменной С, после выполнения следующего алгоритма: А = 3 В = 9 С = 0 пока B>A если А + C > B то С = C + 1 A = A + 2 иначе С = C + 2 B = B + 1

+5
Ответы (1)
  1. 16 мая, 06:08
    0
    Решим эту задачу на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть a, b, c - заданные величины целого типа. Будем использовать оператор цикла с предусловием while и оператор проверки условия if. Тогда программа может выглядеть так:

    program zadacha;

    uses crt;

    var a, b, c: integer;

    begin

    a:=3; b:=9; c:=0; {Задание исходных значений величин a, b, c}

    while b>a do

    if a+c>b then begin

    c:=c+1; a:=a+2;

    end

    else

    begin c:=c+2; b:=b+1;

    end;

    writeln ('c=', c) {Вывод полученного значения величины с на экран}

    end.

    После выполнение данной программы получим, что значение величины с станет равной 21.

    Ответ: с = 21.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислите, чему равняется значение переменной С, после выполнения следующего алгоритма: А = 3 В = 9 С = 0 пока B>A если А + C > B то С = C ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
Определи значение переменной a после выполнения фрагмента алгоритма при a=3 и a=6. Ввод а если a>5 то a:=a+20 иначе a:=a*10 всё Ответ: при a=3 значение переменной a равно?, при a=6 значение переменной a равно?
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной а будет присвоено значение переменной Ь, переменной b - значение переменной с, а переменной с - значение переменной а. Используйте не более одной промежуточной переменной.
Ответы (1)