Задать вопрос

Дан массив из 10 элементов, заполненных случайным образом, в диапазоне от - 6 до 18. Замените нечетные элементы 0 и подсчитайте сумму элементов, кратных 3.

+3
Ответы (1)
  1. 18 октября, 13:56
    0
    program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (25) - 6;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    begin

    if (m[i] mod 2 = 1) or (m[i] mod 2 = - 1) then m[i]:=0;

    if m[i] mod 3 = 0 then s:=s + m[i];

    end;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln (' сумма элементов кратных трем = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из 10 элементов, заполненных случайным образом, в диапазоне от - 6 до 18. Замените нечетные элементы 0 и подсчитайте сумму ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)