Задать вопрос
27 ноября, 07:19

Напишите программу поиска наибольшего из четырех чисел с использованием подпрограммы поиска наибольшего из трёх чисел.

+1
Ответы (1)
  1. 27 ноября, 07:33
    0
    var a, b, c, d: integer;

    function naim (af, bf, cf: integer) : integer;

    var min: integer;

    begin

    if af < bf then min : = af else min : = bf;

    if cf < min then min : = cf;

    naim : = min;

    end;

    begin

    writeln ('Введите a');

    readln (a);

    writeln ('Введите b');

    readln (b);

    writeln ('Введите c');

    readln (c);

    writeln ('Введите d');

    readln (d);

    if naim (a, b, c) > d then writeln (naim (a, b, c)) else writeln (d);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу поиска наибольшего из четырех чисел с использованием подпрограммы поиска наибольшего из трёх чисел. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Написать программу на языке паскаль при помощи подпрограммы функции которая вычисляет минимальное из чисел a b c d
Ответы (1)
Пронумеруй последовательность действий для поиска информации по ключевому слову. Нажать кнопку Найти или Поиск. Открыть программу браузер. Набрать ключевые слова в окне поиска.
Ответы (1)
Дан массив A [1 ... 18, 1 ... n] и натуральное число n. Составить программу поиска наибольшего по модулю элемента массива, а также индекса этого элемента.
Ответы (1)
Для решения задачи сделать вариант программы с реализацией указанной подпрограммы в виде функции или в виде процедуры.
Ответы (1)