Задать вопрос

Дан массив из 10 целых чисел от - 20 до 20 и целое число (вводится с клавиатуры). Напишите программу, определяющую, сколько в массиве чисел.

+2
Ответы (1)
  1. 10 июля, 07:00
    0
    program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    write (' введите заданное число ');

    read (s);

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (41) - 20;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] = s then k:=k + 1;

    writeln (' элементов равных заданному = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из 10 целых чисел от - 20 до 20 и целое число (вводится с клавиатуры). Напишите программу, определяющую, сколько в массиве чисел. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан массив из N целых элементов и целое число B. Написать программу, определяющую, сколько в массиве чисел, меньших В.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)