Задать вопрос

Запишите программу формирования и вывода массива из 20 случайных чисел (из диапазона от 0 да 1000) и вычисления их среднего значения

+5
Ответы (1)
  1. 2 июля, 10:32
    0
    Var

    m:array[1 ... 100] of integer;

    i, s, n:longint;

    a:real;

    begin

    randomize;

    writeln ('Массив:');

    for i:=1 to 20 do

    begin

    m[i]:=random (1001);

    write (m[i],' ');

    s:=s+m[i];

    end;

    a:=s/20;

    writeln ('Среднее арифметическое: ', a:2:3);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Запишите программу формирования и вывода массива из 20 случайных чисел (из диапазона от 0 да 1000) и вычисления их среднего значения ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Найти сумму всех элементов массива целых чисел, которые меньше среднего арифметического элементов массива. Размерность массива-20. Заполнение массива осуществить случайными числами от 150 до 300
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)