Задать вопрос

из 10 вводимых чисел найти количество отрицательных

+3
Ответы (1)
  1. 2 ноября, 06:20
    0
    program zz1;

    var i, s, n:integer; / / задаем переменные целого типа

    begin

    for i:=1 to 10 do / / организуем цикл на десять повторений

    begin

    read (n); / / вводим очередное число

    if n < 0 then s:=s + 1; / / проверяем условие, если введенное число отрицательное, то считаем его

    end;

    writeln (' количество отрицательных чисел среди введенных = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «из 10 вводимых чисел найти количество отрицательных ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел, вводимых клавиатуры. Признак конца ввода чисел 0. Количество введенных чисел заранее неизвестно.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Ввести одно число, указывающие количество вводимых двузначных чисел. Из введенных двузначных чисел найти количество четных.
Ответы (1)
Составить массив из диапазона отрицательных и положительных чисел, найти в нем количество отрицательных чисел.
Ответы (1)
В одну и ту же числовую переменную последовательно вводятся целые числа. Количесвто вводимых чисел заранее известно (0 - конец ввода). Определить количество чисел не кратных 5.
Ответы (1)