Задать вопрос

В паскале написать программу: Вывести среднее арифметическое двузначных четных чисел

+2
Ответы (1)
  1. 21 ноября, 18:43
    0
    Диапазон двузначных чисел - 10 ... 99.

    В этих пределах выполняется цикл суммирования четных чисел и подсчет их количества.

    program aver;

    var n, s: integer;

    begin

    s: = 0;

    n: = 0;

    for i: integer: = 10 to 99 do

    if i mod 2 = 0 then

    begin

    s: = s + i; / /сумма четных чисел

    n: = n + 1 / /количество четных чисел

    end;

    writeln ('Среднее арифметическое двузначных четных чисел: ', s / n)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В паскале написать программу: Вывести среднее арифметическое двузначных четных чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Дан набор ненулевых чисел, признак его завершения число 0. вывести сумму всех положительных четных чисел из данного набора. если требуемые числа отсутсвуют вывести то вывести 0
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)