Задать вопрос

Чему будет равен результат выполнения программы, если ввести значения для a=16 program c22; var a:integer; begin readln (a); if (a mod 2=0) then a:=a div 2; write (a); end

+1
Ответы (1)
  1. Единственное условие в данной программе - if a mod 2 = 0. Проверим, выполняется ли оно при значении переменной a, равном 16. 16 / 2 = 8, остаток от деления - 0. Следовательно, данное условие выполняется, а значит, что можно перейти к операции a : = a div 2. Присваиваем a значение равное целому остатку от деления a на 2. Его мы уже нашли - 8. Значит оператор write выведет на экран число "8".

    Ответ: 8.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Чему будет равен результат выполнения программы, если ввести значения для a=16 program c22; var a:integer; begin readln (a); if (a mod 2=0) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)