Задать вопрос
18 марта, 08:35

Написать программы заполнения массива из 10 чисел: а) первыми десятью нечетными числами; б) случайными числами в интервале от 5 до 15. Все массивы вывести на экран в строку.

+5
Ответы (1)
  1. 18 марта, 10:20
    0
    Код на С++

    #include

    #include

    #include

    #include

    using namespace std;

    void main ()

    {

    SetConsoleCP (1251);

    SetConsoleOutputCP (1251);

    srand (time (NULL));

    int const N = 10;

    int mas1[N];

    int mas2[N];

    for (int i = 0; i < N; i++)

    {

    mas1[i] = rand () % 11 + 5;

    cout << mas1[i] << " ";

    }

    cout << endl;

    for (int i = 1, j = 0; j < N; i++)

    {

    if (i % 2! = 0)

    {

    mas2[j] = i; j++;

    }

    }

    for (int j = 0; j < N; j++)

    cout << mas2[j] << " ";

    system ("pause"); }
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программы заполнения массива из 10 чисел: а) первыми десятью нечетными числами; б) случайными числами в интервале от 5 до 15. Все ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составьте программу, которая заполняет массив А[1 ... 8] случайными целыми числами в диапазоне от 10 до 20. Замените все элементы массива меньше 15 их удвоенными значениями. Вывести на экран первоначальный и преобразованный массивы в строку
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)