Задать вопрос

С клавиатуры последовательно вводятся 15 разных целых чисел, которые размещаются в массиве. Напишите программу, которая выводит на экран количество элементов массива кратных 5 и минимальное среди подходящих под это условие.

+2
Ответы (1)
  1. 10 октября, 17:28
    0
    var

    min, i, x : integer; / / объявляем переменные целочисленного типа.

    arr : array [1 ... 15] of integer; / / объявляем массив.

    Begin

    writeln ('Введите 15 целых чисел для заполнения массива:'); / / вывод строки на экран.

    for i: = 1 to 15 do / / начало цикла.

    begin

    readln (arr[i]); / / заполняем элемент массива.

    if ((arr[i] mod 5 = 0)) then / / если элемент кратный 5.

    begin

    if (x = 0) then min : = arr[i]; / / первый элемент, кратный 5 считаем минимальным.

    if (arr[i] < min) then min : = arr[i]; / / сравниваем текущий элемент с минимумом.

    x : = x + 1; / / считаем количество элементов, кратных 5.

    end;

    end;

    writeln ('Количество элементов в массиве, кратных 5 равно: ', x, ', минимальный из них: ', min);

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры последовательно вводятся 15 разных целых чисел, которые размещаются в массиве. Напишите программу, которая выводит на экран ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)
Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов. программа: Pascal ABC.
Ответы (1)