Задать вопрос

С клавиатуры вводится 4-значное число. Если первая и последняя цифры равны - вывести на экран их сумму, если нет - вывести слово "нет"

+2
Ответы (1)
  1. 26 августа, 11:59
    0
    var

    a, b, s, s1, i: integer; / / объявляем переменные целочисленного типа.

    begin

    write ('Введите число:'); / / вывод строки на экран.

    read (a); / / считываем число, введенное с клавиатуры.

    while a > 0 do / / начало цикла.

    begin

    b : = a mod 10; / / определяем последнюю цифру числа.

    if i = 0 then s : = b; / / запоминаем последнюю цифру.

    if i = 3 then s1 : = b; / / запоминаем первую цифру.

    a : = a div 10; / / удаляем последнюю цифру из числа.

    i : = i + 1; / / счетчик цифр.

    end;

    if (s = s1) then writeln ('Сумма чисел равна: ', s + s1) / / вывод суммы чисел на экран.

    else writeln ('Нет.');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводится 4-значное число. Если первая и последняя цифры равны - вывести на экран их сумму, если нет - вывести слово "нет" ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
2. С клавиатуры вводится трёхзначное число. Вывести на экран двузначное число, состоящее из первой и последней цифры введенного числа. Пример: ввели число 672. Выводим на экран число 62.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)