Задать вопрос

2. С клавиатуры вводится трёхзначное число. Вывести на экран двузначное число, состоящее из первой и последней цифры введенного числа. Пример: ввели число 672. Выводим на экран число 62.

+4
Ответы (1)
  1. 5 июля, 02:31
    0
    program zz1;

    var i, s, k, p:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное трехзначное число ');

    read (i); / / вводим с клавиатуры число

    p:=i mod 10; / / находим последнюю цифру трехзначного числа

    k:=i div 100; / / находим первую цифру трехзначного числа

    s:=k * 10 + p; / / формируем новое двухзначное число

    writeln (' полученное двухзначное число = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «2. С клавиатуры вводится трёхзначное число. Вывести на экран двузначное число, состоящее из первой и последней цифры введенного числа. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
с клавиатуры вводится 2 числа А и В. Если А-нечетное, то вычисляем А+В, иначе А*В. Результат вычисленный выводим на экран составить программу для паскаля
Ответы (1)
С клавиатуры вводится трёхзначное число. Нужно вывести ответ "Да", если все его цифры четные, и ответ "Нет" в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение "Неверное число".
Ответы (1)
С клавиатуры вводится 4-значное число. Если первая и последняя цифры равны - вывести на экран их сумму, если нет - вывести слово "нет"
Ответы (1)