Задать вопрос

В паскале (ABC) с помощью процедуры (любым способом) написать задачу: Прямоугольник задан своими координатами, вычислить периметр.

+5
Ответы (1)
  1. 23 февраля, 10:48
    0
    program zz1;

    var

    x1, x2, x3, x4, y1, y2, y3, y4:integer; / / задаем переменные целого типа

    p, k:real;

    procedure pr (f1, f2, g1, g2:integer; var f:real); / / описываем процедуру

    begin

    f:=sqrt (sqr (f1-g1) + sqr (f2-g2));

    end;

    begin

    write (' введите координаты первого угла прямоугольника ');

    read (x1, y1);

    write (' введите координаты второго угла прямоугольника ');

    read (x2, y2);

    write (' введите координаты третьего угла прямоугольника ');

    read (x3, y3);

    write (' введите координаты четвертого угла прямоугольника ');

    read (x4, y4);

    pr (x1, y1, x2, y2, k);

    p:=p + k;

    pr (x1, y1, x4, y4, k);

    p:=p + k;

    pr (x3, y3, x2, y2, k);

    p:=p + k;

    pr (x3, y3, x4, y4, k);

    p:=p + k;

    write (' периметр прямоугольника = ', p);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В паскале (ABC) с помощью процедуры (любым способом) написать задачу: Прямоугольник задан своими координатами, вычислить периметр. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
Помогите с программой в паскале с помощью процедуры Процедура выводит N целых случайных чисел с интервала a, b
Ответы (1)
1) задан массив из N элементов. вычислить среднее арифметическое тех элементов, которые кратны 3. 2) Задан массив из N элементов. Сформировать новый массив из элементов, кратных 7.
Ответы (1)
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)
Исполнитель Чертёжник перемещается на координатной плоскости, оставляя след в виде линии. Чертёжник может выполнять команду Сместиться на (a, b) (где a, b - целые числа), перемещающую Чертёжника из точки с координатами (x, y), в точку с координатами
Ответы (1)