Задать вопрос

Составьте программу сортировки по возрастанию значений трех переменных A; B; C

+5
Ответы (1)
  1. 3 августа, 15:20
    0
    var

    a, b, c: longint;

    begin

    writeln ('Введите переменную a: ');

    readln (a);

    writeln ('Введите переменную b: ');

    readln (b);

    writeln ('Введите переменную c: ');

    readln (c);

    if (a > b) and (a > c) and (b > c) then writeln (c, b, a) else

    if (b > a) and (b > c) and (c > a) then writeln (a, c, b) else

    if (c > a) and (c > b) and (a > b) then writeln (b, a, c) else

    if (b > a) and (b > c) and (a > c) then writeln (c, a, b) else

    if (c > a) and (c > b) and (b > a) then writeln (a, b, c) else

    if (a > b) and (a > c) and (c > b) then writeln (b, c, a)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу сортировки по возрастанию значений трех переменных A; B; C ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы