Задать вопрос
25 июля, 16:59

вводятся числа, считается сумма двузначных чисел и произведение однозначных. Ввод оканчивается нулем. Вывести на экран сумму и произведение. Цикл while

+4
Ответы (1)
  1. 25 июля, 19:08
    0
    Program / /название программы в некоторых версиях;

    var

    a, d, d1: integer; / /переменные целого типа;

    begin

    randomize; / /подключаем генератор случайных числе;

    a:=random (90) + 10; / /используем случайное число;

    d:=a mod 10; / /1 цифра которая делится на 10;

    d1: = a div 10; / /2 цифра остаток;

    writeln ('число: ', a); / /Вводим число а;

    writeln ('сумма: ', d+d1); / /вывод суммы на экран;

    writeln ('произведение: ', d*d1) / /вывод произведения на экран;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «вводятся числа, считается сумма двузначных чисел и произведение однозначных. Ввод оканчивается нулем. Вывести на экран сумму и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Составить алгоритм сложения двух целых чисел F и Q, вводимых с клавиатуры. Результат сложения записать в виде переменной W. По данному алгоритму написать программу в Паскале. алг сложение цел F, Q, W нач ввод F ввод Q W:=F+Q вывод W кон 2.
Ответы (1)
Соедини стрелками устройства компьютера с их функциями. Процессор Отображение данных на экране Монитор - Ввод текста и чисел Сканер Обработка данных Клавиатура Ввод графических данных Принтер Вывод звуковых данных Наушники Ввод звуковых данных
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)