Задать вопрос
17 ноября, 00:08

Вычислить сумму четных целых чисел из (n, m)

+5
Ответы (1)
  1. 17 ноября, 02:35
    0
    program zz1;

    var n, m, r, i:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (n);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (m);

    for i:=n to m do / / организуем цикл, в котором переберем все числа от n до m

    if i mod 2 = 0 then r:=r + i; / / проверяем число на четность и вычисляем сумму четных чисел от n до m по формуле

    write (' сумма четных чисел от ', n,' до ', m,' = ', r); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить сумму четных целых чисел из (n, m) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
Пользователь вводит число N программа считает сумму четных чисел до N и сумму не четных чисел до N. Написать алгоритм решения
Ответы (1)
А) Вывести на экран квадрат первых двадцати нечетных чисел. Б) Найти сумму n четных чисел, количество четных чисел задается в процессе работы программы.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)