Задать вопрос

Пользователь вводит число N программа считает сумму четных чисел до N и сумму не четных чисел до N. Написать алгоритм решения

+4
Ответы (1)
  1. 24 января, 21:11
    0
    var

    N, i, sum: integer;

    begin

    writeln ('Введите N:');

    readln (N);

    sum : = 0;

    for i : = 1 to N do

    if (i mod 2) = 0 then

    sum + = i;

    write ('Сумма четных чисел = ', sum);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Пользователь вводит число N программа считает сумму четных чисел до N и сумму не четных чисел до N. Написать алгоритм решения ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Все нужно сделать на Pascal'e. Пользователь вводит с клавиатуры целое положительное пятизначное число. Программа определяет цифру десятков, цифру сотен и цифру тысяч во введенном числе.
Ответы (1)
Как написать программу для pascal abc которая считает факториал числа который вводит пользователь
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Напишите программу, в которой пользователь вводит 3 дробных числа А В и С. Программа должна определить какое из трёх чисел максимальное (самое большое) и вывести его на экран
Ответы (1)