Задать вопрос

Среди чисел последовательности 1,2,3,5,8,13 ... (каждый следующий член последовательности равен сумме двух предыдущих) найдите количество чисел до первого 6-значного Pascal abc

+1
Ответы (1)
  1. 29 июня, 10:30
    0
    program numb;

    var n1, n2, n3, k:integer;

    begin

    n1: = 1;

    n2: = 2;

    k: = 2;

    repeat

    n3: = n1 + n2;

    n1: = n2; n2: = n3;

    k: = k + 1

    until n3 > 999999;

    writeln ('Количество чисел до первого шестизначного: ', k - 1);

    writeln ('Последнее число перед первым шестизначным: ', n1)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Среди чисел последовательности 1,2,3,5,8,13 ... (каждый следующий член последовательности равен сумме двух предыдущих) найдите количество ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана непустая последовательность чисел оканчивающаяся нулем. Найти: а) сумму всех чисел последовательности, б) кол-во всех чисел последовательности. решить через Pascal ABC через repeat, for или while
Ответы (1)
Выполнить алгоритм: 1) Найти сумму чисел 1 и 3; 2) Прибавить к полученной сумме число 5; 3) Прибавить к полученной сумме число 7; 4) Прибавить к полученной сумме число 9; 5) Прибавить к полученной сумме число 11; 6) Сообщить результат
Ответы (1)
Составить программу Pascal : Найти произведение цифр заданого 3 х значного числа.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)