Задать вопрос

Дано натуральное число. Найдите число десятков в его десятичной записи (то есть вторую справа цифру его десятичной записи).

+4
Ответы (1)
  1. 16 сентября, 09:43
    0
    program zz1;

    var n, k:integer; / / задаем переменные целого типа

    begin

    write (' введите число ');

    read (n); / / вводим с клавиатуры число

    k: = (n mod 100) div 10; / / получаем количество десятков в заданном числе

    writeln (' количество десятков в заданном числе = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число. Найдите число десятков в его десятичной записи (то есть вторую справа цифру его десятичной записи). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
Все нужно сделать на Pascal'e. Пользователь вводит с клавиатуры целое положительное пятизначное число. Программа определяет цифру десятков, цифру сотен и цифру тысяч во введенном числе.
Ответы (1)
Дано целое неотрицательное число N, определите число десятков в нем (предпоследнюю цифру числа). Если предпосленей цифры нет, то можно считать, что число десятков равно нулю. (Напишите программу для решения в Pascal. ABC)
Ответы (1)