Задать вопрос
20 сентября, 08:04

1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

+1
Ответы (1)
  1. 20 сентября, 09:04
    0
    1) Просим пользователя программы ввести число

    writeln ('Введите натуральное число');

    readln (a);

    Запускаем цикл. Важно уточнить, что он длится до длины числа, меньшей на единицу, потому что будет ошибка, если этого не сделать.

    Тогда цикл выйдет за допустимые границы.

    for i:integer : = 1 to (length (a) - 1) do

    if a[i] = a[I + 1] then

    begin

    writeln ('Верно');

    break;

    end;

    else

    writeln ('Не верно');

    2) Тут будем использовать такой же цикл, но он будет сравнивать каждую цифру с каждой другой цифрой. И как только найдутся одинаковые значения, программа покинет цикл с помощью оператора break:

    for i:integer : = 1 to (length (a) - 1) do

    for j:integer : = 1 to length (a) do

    if a[i] = a[j] then

    begin

    writeln ('Верно');

    break; - этот оператор поможет не выполнять лишнюю работу.

    end;

    else

    writeln ('Не верно');
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры. Например, 1234 - нет; 1224 - да. Обязательно должен присутствовать цикл с предусловием while do. Информатика. 8 класс. Паскаль ABC.
Ответы (1)
Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом
Ответы (1)
Ввести натуральное число и определить, верно ли, что сумма его цифр равна10.
Ответы (1)