Задать вопрос

В массиве а (50), заполненный случайными числами. Найти количество отрицательных чисел

+2
Ответы (1)
  1. 16 сентября, 20:06
    0
    program zz1;

    var mas:array[1 ... 50] of integer;

    i, k:integer;

    begin

    for i:=1 to 50 do / / записываем в массив 50 "случайных" чисел от - 50 до 50

    mas[i]:=random (101) - 50;

    for i:=1 to 50 do

    write (mas[i],' '); / / выводим все числа из массива на экран в строчку через пробел

    writeln; / / переходим на новую строку для вывода

    for i:=1 to 50 do

    if mas[i]<0 then k:=k+1; / / проверяем, если элемент массива отрицательный, то считаем его

    write ('количество отрицательных чисел = ', k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве а (50), заполненный случайными числами. Найти количество отрицательных чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9. Сформировать новый массив из значений элементов, стоящих на четных местах. Подсчитать количество отрицательных и положительных значений элементов в новом массиве.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от - 20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. (на паскале)
Ответы (1)
Оставить программу заполнения массива из 100 чисел случайными значениями из диапозона от - 20 до 20. подсчитайте в этом массиве количество положительных и количество отрицательных значений.
Ответы (1)