Задать вопрос

1. Найти значение Y, которое равно квадрату заданного числа Х, если Х>2, и равно 4 в остальных случаях. 2. Найти значение Y при заданном X : 3X+9, если X<7 (X) + 1, если X>7

+4
Ответы (1)
  1. 1 декабря, 00:48
    0
    1. program zz1;

    var x, y:integer; / / вводим переменную целого типа

    begin

    write (' введите x '); / / вводим с клавиатуры число

    read (x);

    if x > 2 / / проверяем условие

    then y:=x * x;

    else y:=4;

    write (' y = ', y); / / выводим ответ

    end.

    2. program zz1;

    var x:integer; / / вводим переменную целого типа

    y:real; / / вводим переменную не целого типа

    begin

    write (' введите x '); / / вводим с клавиатуры число

    read (x);

    if x < 7 / / проверяем условие

    then y:=3 * x + 9;

    if x > 7 / / проверяем условие

    then y:=sin (x) + 1;

    write (' y = ', y); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Найти значение Y, которое равно квадрату заданного числа Х, если Х>2, и равно 4 в остальных случаях. 2. Найти значение Y при заданном X ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
В заданном массиве А (m, n) найти количество положительных элементов по столбцам. Образовать массив B (m, n), делением элементов заданного массива на найденное количество положительных элементов по столбцам.
Ответы (1)
1. Составить программу, которая определяет, сколько в заданном предложении букв "ф". Если такой буквы нет, то на экран вывести слово " нет" 2. Составить программу, в заданном предложении все слова "мой" удалить.
Ответы (1)
1) Написать программу, которая находит в массиве случайных символов первое вхождение заданного символа.
Ответы (1)
Дано два числа. если числа четны, то вычислите их произведение, если числа не четны, то их сумму, в остальных случаях вычислите разность этих чисел.
Ответы (1)
Даны действительные числа a, b. Вывести на экран сообщение "Числа лежат в заданном промежутке", если они принадлежат интервалу (x0, x1] и "Числа вне интервала" в противном случае (приделы интервала x0 и x1 вводятся с клавиатуры)
Ответы (1)