Задать вопрос
13 февраля, 10:01

Дано натуральное число n. Определить: a) Количество цифр в этом числе; б) Сумму его цифр; в) Первую цифру числа n;

+3
Ответы (1)
  1. 13 февраля, 12:20
    0
    program zz1;

    var s, n, k, i:integer; / / задаем переменные целого типа

    begin

    write (' введите число ');

    read (n); / / вводим с клавиатуры число

    s:=0;

    while n>0 do / / организуем цикл, пока в числе есть цифры

    begin

    k:=n mod 10; / / получаем последнюю цифру

    s:=s + k; / / прибавляем ее к сумме

    n:=n div 10; / / отбрасываем ее

    i:=i + 1; / / считаем ее

    end;

    writeln ('количество цифр числа = ', i); / / выводим ответ

    writeln ('сумма цифр четырехзначного числа = ', s);

    writeln ('первая цифра числа = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число n. Определить: a) Количество цифр в этом числе; б) Сумму его цифр; в) Первую цифру числа n; ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
1. Дано натуральное число: 1) найти количество цифр данного числа 2) Верно ли что данное число оканчивается на нечетную цифру
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)