Задать вопрос

1. Дано натуральное число: 1) найти количество цифр данного числа 2) Верно ли что данное число оканчивается на нечетную цифру

+3
Ответы (1)
  1. 31 октября, 09:15
    0
    program zz1;

    var n, k, m, b:integer;

    begin

    writeln ('Введите исходное натуральное число');

    read (n); / /Вводим исходное число

    while n>0 do / /заводим цикл пока число больше нуля

    begin

    m:=n mod 10; / /получаем последнюю цифру

    n:=n div 10; / /отбрасываем последнюю цифру

    k:=k+1; / /считаем цифру

    if k=1 then b:=m; / /запоминаем последнюю цифру числа

    end;

    writeln ('Количество цифр в исходном числе - ', k); / /выводим ответ

    if b mod 2 = 0 then write ('Число не оканчивается на нечетную цифру') / /проверяем последнюю цифру на нечетность

    else write ('Число оканчивается на нечетную цифру');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Дано натуральное число: 1) найти количество цифр данного числа 2) Верно ли что данное число оканчивается на нечетную цифру ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
Дано натуральное число n. Определить: a) Количество цифр в этом числе; б) Сумму его цифр; в) Первую цифру числа n;
Ответы (1)
Дано n натуральное. найти и вывести все числа в интервале от 1 до n-1, у которых произведение всех цифр совпадает с суммой цифр данного числа. Если таких чисел нет вывести "Нет". Паскаль
Ответы (1)