Задать вопрос
23 февраля, 18:40

Заполните массив 15 произвольными целыми числами, введя их с клавиатуры и найдите среди них среднее арифметическое.

+2
Ответы (1)
  1. 23 февраля, 19:19
    0
    var a: array[1 ... 15] of integer;

    i, sum, srar, j: integer;

    begin

    writeln ('Заполните массив с клавиатуры');

    for i:=1 to 15 do readln (a[i]);

    for i:=1 to 15 do

    begin

    n:=n+1;

    sum:=sum+a[i];

    end;

    srar:=sum mod n;

    writeln ('Среднее арифметическое 15-и введённых с клавиатуры чисел равно ', srar);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Заполните массив 15 произвольными целыми числами, введя их с клавиатуры и найдите среди них среднее арифметическое. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Дан массиа А, состоящий из 12 чисел, массив заполнить случайными числами в диапазоне от 0 до 100. Требуется подсчитать среднее арифметическое значение элементов массива. на экран вывести массив и среднее арифметическое
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Напишите программу, которая заполняет массив случайными целыми числами, вводит с клавиатуры целое число N и копирует в новый массив все числа из исходного массива, для которых сумма значений всех цифр равна N.
Ответы (1)