Задать вопрос

Составьте программу которая вычисляет значение выражения - 2^2+2^3-2^4+2^5-2^6

+4
Ответы (1)
  1. 6 июля, 11:50
    0
    Составим программу на языке программирования Паскаль, которая будет вычислять значение заданного выражения: - 2^2 + 2^3 - 2^4 + 2^5 - 2^6.

    1) programm vychislenie;

    var s, a, b, c, d, e: integer;

    begin

    a: = sqr (2);

    b: = 2 * a;

    c: = sqr (a);

    d: = 2 * c;

    e: = sqr (b);

    s: = - a + b - c + d - e;

    writeln ('Значение исходного выражения равно', s);

    end.

    2) Также можно написать программу следующим образом:

    programm vychislenie;

    var s: integer;

    begin

    s: = - exp (2 * ln (2)) + exp (3 * ln (2)) - exp (4 * ln (2)) + exp (5 * ln (2)) - exp (6 * ln (2));

    writeln ('Значение исходного выражения равно', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу которая вычисляет значение выражения - 2^2+2^3-2^4+2^5-2^6 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы