Задать вопрос

1. напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных семи и оканчивающихся на один количество не известно 2. напишите программу которая в последовательности натуральных чисел определяет количество чисел кратных пяти и оканчивающийся на ноль.

+5
Ответы (1)
  1. 18 февраля, 03:33
    0
    1. program zz1;

    var a, n, i, s:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим заданное n

    read (n);

    for i:=1 to n do

    begin

    read (a); / / вводим число последовательности

    if (a mod 7 = 0) and (a mod 10 = 1) then s:=s+1;

    end;

    writeln ('количество чисел кратных семи и заканчивающихся на 1 = ', s); / / выводим ответ

    end.

    2. program zz1;

    var a, n, i, s:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим заданное n

    read (n);

    for i:=1 to n do

    begin

    read (a); / / вводим число последовательности

    if (a mod 5 = 0) and (a mod 10 = 0) then s:=s+1;

    end;

    writeln ('количество чисел кратных пяти и заканчивающихся на 0 = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных семи и оканчивающихся на один ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)
напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 6 и оканчивающихся на 4. Программа получает на ввод натуральные числа, количество введенных чисел неизвестно.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4.
Ответы (1)