Задать вопрос

Найти все двузначные числа, сумма цифр которых не меняется при умножении числа на 2,3,4,5,6,7,8,9

+3
Ответы (1)
  1. 2 апреля, 20:51
    0
    program zz1;

    var a, s1, n, i, s2, b, k, j:integer; / / задаем переменные целого типа

    begin

    for j: = 2 to 9 do

    begin

    writeln (' двузначные числа при умножении на ', j);

    for i:=10 to 99 do

    begin

    s1:=0; s2:=0;

    a:=i mod 10;

    b:=i div 10;

    s1: = a + b;

    n:=i*j;

    while n > 0 do / / организуем цикл, пока в числе есть цифры

    begin

    k:=n mod 10; / / получаем последнюю цифру

    s2:=s2 + k; / / прибавляем ее к сумме

    n:=n div 10; / / отбрасываем ее

    end;

    if s1 = s2 then write (' ', i); / / выводим ответ

    end;

    writeln;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти все двузначные числа, сумма цифр которых не меняется при умножении числа на 2,3,4,5,6,7,8,9 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Найдите и выведите на экран все двузначные числа, сумма цифр которых не меняется при умножении на 2
Ответы (1)
Найдите и выведите на экран все двузначные числа, у которых при умножении на 2 сумма цифр увеличивается на 5. Определите количество этих чисел.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)
Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры.
Ответы (1)