Задать вопрос

1) Напишите программу в Паскале Заполнить массив случайными целыми числами. Заменить элементы массива, кратные K нулями, остальные 1 (К ввести с клавиатуры)

+3
Ответы (1)
  1. 10 июня, 11:52
    0
    Program mass;

    const N=10;

    var a:array [1 ... N] of integer; i, k: integer;

    begin

    randomize;

    for i:=1 to N do

    begin

    a[i]: = random (1000);

    write (a[i],' ');

    end;

    writeln;

    writeln ('Введите целое число k');

    readln (k);

    for i:=1 to N do

    begin

    if a[i] mod k = 0 then a[i]:=0 else a[i]:=1;

    write (a[i], ' ');

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Напишите программу в Паскале Заполнить массив случайными целыми числами. Заменить элементы массива, кратные K нулями, остальные 1 (К ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)