Задать вопрос

1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ... 8]случайными целыми числами в диапазоне от 1 до 22 и заменяет все отрицательные элементы на - 9.

+5
Ответы (1)
  1. 25 января, 18:27
    0
    1.

    program zz1;

    const n = 12; / / задаем количество элементов в массиве

    var i, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21) - 10;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    if m[i] < 0 then k:=k+1; / / получаем количество отрицательных элементов

    writeln;

    write (' количество отрицательных элементов массива = ', k); / /выводим ответ

    end.

    2.

    program zz1;

    const n = 8; / / задаем количество элементов в массиве

    var i, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (22) + 1;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    if m[i] < 0 then m[i]:=-9; / / получаем количество отрицательных элементов

    writeln;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов =
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и вычисляет произведение элементов массива с чётными значениями и среднее арифм. элементов массива с нечётными значениями
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Составьте программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Составьте программу, которая заполняет массив А[1 ... 8] случайными целыми числами в диапазоне от 10 до 20. Замените все элементы массива меньше 15 их удвоенными значениями. Вывести на экран первоначальный и преобразованный массивы в строку
Ответы (1)