Задать вопрос
6 июля, 12:47

Вводятся величины X, Y целого типа. Написать программу для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать программу для X=5 и Y=-11.

+5
Ответы (1)
  1. 6 июля, 13:06
    0
    program zz1;

    var x, y, t:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число x = '); / / вводим с клавиатуры первое число

    read (x);

    write (' введите второе число y = '); / / вводим с клавиатуры второе число

    read (y);

    t:=x; x:=y; y:=t; / / производим обмен

    write (' x = ', x, ' y = ', y); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вводятся величины X, Y целого типа. Написать программу для обмена значений величин. Необходимо использовать вспомогательную величину Т. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Установите соответствие. График Служит для сравнения нескольких величин в нескольких точках Круговая диаграмма Позволяет отслеживать динамику изменения данных Столбчатая диаграмма Позволяет наглядно сравнить суммы нескольких величин в нескольких
Ответы (1)
Написать программу, которая запрашивает массив размерности N и выводит на экран сам массив, а также наибольший и наименьший элементы массива. Протестировать программу на массивах размерностью 5 и 10 элементов.
Ответы (1)
Написать на языке паскаль программу ввода четырех целых чисел и вычисления их среднего арифметического. протестировать программу на различных исходных данных и доказать правильность ее работы
Ответы (1)
Дано натуральное число Х. Вычислить Y = 1 - 2X + 3X2 (в квадрате) - 4X3 (в третьей степени). Разрешается использовать не более 8 арифметических операций. Допустимы: операции сложение, вычитание, умножение. Протестировать программу для X=0, X=1, X=-2.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)