Задать вопрос
29 марта, 23:37

Дано двузначное число. Переставить его цифры и вывести отвеи. В програме Паскаль. Со всеми кодами.

+1
Ответы (1)
  1. 30 марта, 02:24
    0
    program zz1;

    var a, b, p, s:integer; / / задаем переменные целого типа

    begin

    write (' введите двузначное число '); / / вводим с клавиатуры двузначное число

    read (a);

    b: = a mod 10; / / находим вторую цифру двузначного числа

    p: = a div 10; / / находим первую цифру двузначного числа

    s:=b * 10 + p; / / получаем новое двузначное число перестановкой цифр

    write (' полученное новое двузначное число = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано двузначное число. Переставить его цифры и вывести отвеи. В програме Паскаль. Со всеми кодами. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Составить программу в Паскаль: Дано трехзначное число определить делится ли оно на 3. Если да - вывести результат деления, если нет вывести фразу - "число не кратно 3".
Ответы (1)